Home | Contact Us

C R A F T

Companion for Reading Authentic Foreign Texts


About CRAFT

The CRAFT software module is designed to facilitate independent structured study of authentic materials on the web. The CRAFT software complements the popular web browsers specified below.

System Requirements

Minimum browser requirements are Netscape 6.1, Mozilla 1.0, and Internet Explorer 5.5 (or later versions).
Browsers must have javascript, cookies, and popup windows enabled.

© 2002 Yale Center for Language Study Contact Us